Incident affecting Search and Kata Editor
Incident Report for Codewars
Resolved
Resolving the incident because Codewars is usable with the fallback.
Posted Nov 19, 2021 - 03:46 UTC
Update
Deployed a basic fallback search for Kata for when Elasticsearch is not available. Please note that some features are limited or missing.

Working on a similar fallback for Collections search.
Posted Nov 18, 2021 - 05:49 UTC
Update
We are still waiting on updates. Thanks for your patience.
Started working on adding a basic fallback search.
Posted Nov 18, 2021 - 05:06 UTC
Update
We are still waiting for an update. Thanks for your patience.

A possible workaround for basic search is to use search engines.
- https://www.google.com/search?q=site:www.codewars.com+inurl:javascript
- https://duckduckgo.com/?q=site:www.codewars.com+inurl:javascript

Replace `javascript` with the language you want.
Posted Nov 17, 2021 - 23:19 UTC
Update
Codewars was updated to fail more gracefully when Elasticsearch is not available. Kata Editor and Collections Search no longer crashes.

Still waiting for updates.
Posted Nov 17, 2021 - 20:13 UTC
Update
We are still waiting for updates.
Posted Nov 17, 2021 - 19:09 UTC
Update
The case was reviewed and escalated. Waiting for update.
Posted Nov 17, 2021 - 10:52 UTC
Update
Opened support case and waiting for response.
Posted Nov 17, 2021 - 09:35 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 17, 2021 - 08:35 UTC
Identified
Our hosted Elasticsearch is down. Kata/collection search page is affected. Kata editor is also affected.
Posted Nov 17, 2021 - 07:33 UTC
This incident affected: Web.